Categoria: debian & ubuntu

[Ubuntu Firefox] "Your browser does not support OpenSearch search plugins"

If you use ubuntu-repo firefox, maybe you’ll get this error

Your browser does not support OpenSearch search plugins

I found, amongst many curious posts, that such behaviour is caused by Unity Desktop Integration (have a look in Firefox extensions)…

Unity Desktop Integration

So, it’s easy, just disable it and restart Firefox

UDI-disabled

then try to add a plugin, from Mycroft site for instance

addOk

And it works!

updated ubuntu on outdated notebook

è successo, insperabilmente, di nuovo
che aggiornare ubuntu su un pc datato – il vecchio notebook compaq del 2007 – non solo abbia funzionato, ma che addirittura abbia migliorato le performance del sistema esistente
fermo restando che continuo a utilizzare gnome (no nuove o più dispendiose shell grafiche, ma nemmeno xfce o altri compromessi minimalisti), e che certamente non ha delle prestazioni eccellenti, ero comunque pessimista, visto che i due ultimi passaggi erano stati disastrosi sia in termini di upgrade della distribuzione che degli effetti collaterali in termini di pesantezza e peggioramento di responsività
non so se il miglioramento sia (solo) nel kernel, ma il lavoro c’è stato e una volta di più fatto bene

Ripristinare il vostro bootloader (grub2)

Sei nelle canne perché qualche applicazione tossica (tipicamente su windows) ti ha corrotto il bootloader?

Avvia una livecd di ubuntu (dalla karmic in poi), e segui queste istruzioni:

Trova la partizione linux su cui ho la mia /boot

 $ sudo fdisk -l

da qui recuperi il device interessato (nel mio caso /dev/sdb1)
e lo monti:

 $ sudo mount /dev/sdb1 /mnt

A questo punto reinstalli grub, indicando la directory montata e il device tipicamente dove si trova il master boot record:

 $ sudo grub-install --root-directory=/mnt/ /dev/sda

Basta riavviare e ritroverete il vostro grub.

Grazie ad Andrea e a questo post.

unity

Schermata
Provando Unity, sia a casa che in ufficio,
ho spesso la sensazione di “smarrimento”.

Per il minore response-feedback (percezione di ~) tra applicazioni e sistema operativo

Per alcune informazioni che sfuggono all’evidenza rispetto a prima
(task aperti, spostamento di finestre da un desktop all’altro, …)

I concetti generali, che solo lontanamente possono ricordare il Mac,
sono abbastanza puliti e azzeccati, ma la usability lascia ancora un po’
l’amaro in bocca.
L’idea di poter sfruttare al meglio la visibilità dei moderni display 16:9
è ben rappresentata, ma la customizzazione degli elementi
caratterizzanti di unity dov’è?

Ho provato il livecd di Gnome3 e mi ha ingolosito molto di più
non vedo l’ora di poterlo installare dai repository Ubuntu

Ubuntu 11.10 e GNOME3…

Ubuntu 11.10, la prossima release, includerà nei propri repository una pacchettizzazione di GNOME 3.0 perfettamente funzionante.

Già da adesso i primi pacchetti di GNOME 3 e di GNOME Shell stanno approdando nei repository principali della distribuzione: molto presto saranno disponibili per un’installazione “stabile”, e non solo. Gli sviluppatori di Ubuntu hanno infatti promesso che gli AppIndicator non saranno invasivi nel caso d’uso del desktop GNOME; al contrario di quanto accadeva con le release fino alla 10.10, in cui comunque gli indicatori venivano caricati a prescindere.

Con la nuova fornitura di GNOME sarà incluso un piccolo controllo, infatti, che abiliterà il supporto a AppIndicator solo in presenza di Unity, di cui abbiamo scritto nei giorni scorsi;

via Ubuntu 11.10 permetterà di installare GNOME3 | oneOpenSource.

Ubuntu Bag

davvero pregevole

image

image

Continua a leggere

Firefox 4 su Ubuntu 10.10 Maverick

Per installare Firefox 4 su Ubuntu, senza aspettare la prossima release, è sufficiente puntare ai repository PPA;
per fare ciò, in giro per il web, è diffuso il suggerimento di utilizzare il comodo comando:

sudo add-apt-repository ppa:mozillateam/firefox-stable
sudo apt-get update && sudo apt-get upgrade

screenshot10

ma magari siete in condizioni particolari (p.e. proxy/firewall) e non riuscite,
e avete bisogno dei passi singoli

ovviamente prima di tutto accertatevi di avere le variabili d’ambiente per il proxy adeguatamente settate #1 #2

per installare la chiave gpg del repository PPA (da fare col proprio utente):

 gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 0A5174AF

poi bisogna editare (passando per sudo) il file /etc/apt/sources.list aggiungendo le righe:

deb http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu maverick main
deb-src http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu maverick main

poi basta aggiornare alla solita maniera e il gioco è fatto:

sudo apt-get update && sudo apt-get upgrade

screenshot11

screenshot12

No input supported

[in ufficio] son riuscito, dopo svariati tentativi, ad aggirare il fastidioso “No Input Supported” sul monitor Acer (senza i driver proprietari della scheda video nvidia)

installando dal cd della Alternate, avendo cura di impostare al boot il parametro:

vga=168

 
 
 
dopo aver installato, nelle opzioni del grub, ho aggiunto

... nomodeset

 
 
 
e l’installer (ncurses)  finalmente è partito

mediacenter low cost

riciclando il mio vecchio pc, l’ho attaccato al televisore del soggiorno

certo, devo ancora capire quale sia la soluzione migliore per l’audio (cavettone lungo nell’ingresso rc-a della tv oppure allo stereo adiacente?)

Ubuntu 40 pollici

ma la ubuntu su un quaranta pollici la prima volta fa un certo effetto 🙂

ubuntu ::: eeepc

nei ritagli di tempo, son riuscito finalmente a ripulire il caro eeepc da un s.o. di redmond e mettergli sopra una distribuzione gnu/linux…

diciamo che ho incontrato qualche intoppo, piu` di sfortuna che di inadeguatezza tecnologica degli strumenti via via provati

prima ho provato la ubuntu netbook remix, usando, per creare l’unita` usb di boot&setup, sia usb-creator (inclusa nella distribuzione netbook remix) che unetbootin

col primo ho fatto l’errore (una volta) di spuntare l’opzione che creava l’immagine riservando dello spazio per salvataggio documenti
dando poi l’errore, appena caricato il kernel, seguente:

Can not mount /dev/loop1 on /cow

23122009172

col secondo invece la netbook remix parte in modalita`  live, ma quando andavo a installarla, si piantava il partizionatore (partman):

allora ho provato, cosi` per valutare, 3 altre distro

ma solo con la EEEbuntu ho ottenuto il risultato voluto: un setup che funziona, riconosce tutto lo hardware correttamente, e soprattutto mi consegna una ubuntu installata in piena regola.

(edit) Ho seguito il consiglio di formattare il disco a ext2 e di non fare una partizione di swap dedicata, per diminuire le scritture e aumentare la vita del disco ssd.

Prima di aggiornare alla 9.10, ho fatto puntare la cache dei pacchetti deb alla sd da 8GB, scrivendo le seguente direttiva in /etc/apt/apt.conf:

Dir::Cache "/media/disk/cache/apt/";


related:

%d blogger hanno fatto clic su Mi Piace per questo: